[J-core] MimasV2Config.py: unable to read SPI Flash ID

Trevor Woerner twoerner at gmail.com
Sun Apr 17 10:36:07 EDT 2016

On Sat 2016-04-16 @ 10:04:20 PM, Christopher Friedt wrote:
> On Sat, Apr 16, 2016 at 7:59 PM, Trevor Woerner <twoerner at gmail.com> wrote:
> > On Sat 2016-04-16 @ 05:39:14 PM, Christopher Friedt wrote:
> >> Trevor, that's exactly what I'm seeing.
> >
> > But in your email thread the console output you pasted shows your script gets
> > beyond the "detection of the SPI Flash" phase. Your output explicitly shows
> > that your flash is detected, then you get errors further along. In my case my
> > script is unable to detect the SPI flash at all, so I'm not sure we're seeing
> > the same error.
> Only rarely did I ever see anything past "Unable to read SPI Flash ID".
> I set up Windows 10 in a VM and the official configuration utility
> worked like a charm.

Ah okay, thanks :-)

> ... still leaning towards rewriting the .py script in C anyway,
> because if I can avoid windows, I will.

I try to avoid making promises... but it's something I'll add to my list ;-)

More information about the J-core mailing list