[J-core] MimasV2Config.py: unable to read SPI Flash ID

Trevor Woerner twoerner at gmail.com
Sat Apr 16 20:03:35 EDT 2016

On Sat 2016-04-16 @ 04:34:05 PM, Rob Landley wrote:
> On 04/16/2016 12:39 PM, Trevor Woerner wrote:
> > I don't know if this is related to the issue Rob is mentioning about pyserial
> > and having to re-run the command a dozen times before it "takes", but no
> > matter how many times I run the MimasV2Config.py command (many dozens of
> > attempts so far) I keep getting:
> > 
> > 	$ sudo python3 MimasV2Config.py /dev/ttyACM0 mimas_v2.bin 
> > 	****************************************
> > 	* Numato Lab Mimas V2 Configuration Tool *
> > 	****************************************
> > 	Unable to read SPI Flash ID
> > 
> > Anyone else seeing this?
> Did you flip the switch?
> (The little black switch between the VGA and USB connectors needs to be
> pointed twoards the USB to program the board, and towards VGA to run as
> j-core.)

Yes :-) But I tried it both ways just to be safe ;-)

I'll keep trying the command and see if I get it.

The board appears to have some already-built-in code that it runs as soon as
it gets power? The LEDs blink in sequence one at a time and the 7-segment
displays count from 0 to 9 then start at 0 again over and over. Running the
flashing program doesn't seem to interrupt this routine.

More information about the J-core mailing list