[J-core] MimasV2Config.py: unable to read SPI Flash ID

Trevor Woerner twoerner at gmail.com
Sat Apr 16 19:59:55 EDT 2016

On Sat 2016-04-16 @ 05:39:14 PM, Christopher Friedt wrote:
> Trevor, that's exactly what I'm seeing.

But in your email thread the console output you pasted shows your script gets
beyond the "detection of the SPI Flash" phase. Your output explicitly shows
that your flash is detected, then you get errors further along. In my case my
script is unable to detect the SPI flash at all, so I'm not sure we're seeing
the same error.

> On Apr 16, 2016 1:39 PM, "Trevor Woerner" <twoerner at gmail.com> wrote:
> > I don't know if this is related to the issue Rob is mentioning about
> > pyserial
> > and having to re-run the command a dozen times before it "takes", but no
> > matter how many times I run the MimasV2Config.py command (many dozens of
> > attempts so far) I keep getting:
> >
> >         $ sudo python3 MimasV2Config.py /dev/ttyACM0 mimas_v2.bin
> >         ****************************************
> >         * Numato Lab Mimas V2 Configuration Tool *
> >         ****************************************
> >         Unable to read SPI Flash ID

More information about the J-core mailing list