[J-core] Raise ice40 issues on GitHub or via the mailing list?

Rob Landley rob at landley.net
Tue Oct 22 08:08:59 UTC 2019

To answer the topic, "we're more likely to see it on the mailing list"?

In theory either should work, in practice the github email notifications go to
an email account nobody regularly reads at the moment. (I should probably make
it cc: mine or jeff's...)

On 10/21/19 7:36 PM, Joh-Tob Schäg wrote:
> Hello,
> i downloaded the most recent release of the j-core-ice40 repo on GitHub.
> It turns out that there are files that are not checked in that are
> necessary to execute ghdl.sh and ghdl_up5k.sh.

I haven't tried that one, I ran ghdl_lattice.sh, which builds fine, but I have
the other version of ghdl installed which needs a slightly different command
line. (One does standalone binaries and the other uses an interpreter to read
the .cf thingy.)

I think Jeff is on a plane back to Japan at the moment, but when he gets out I
can poke him about a reproduction sequence. (I had it working but did a git
checkout that reverted my copy of the ghdl_lattice.sh file meaning the changes
to the run line got reverted. I remember it started with "ghdl -r" but what the
rest of the chagnes were... something about a different time format I think?

ghdl --help says:

-r,--elab-run [OPTS] UNIT [ARCH] [RUNOPTS]  Run UNIT

> ghdl.sh throws these errors:
> cpu_pure_tb.vhh:104:17:error: no declaration for "dev_ddr"
> cpu_pure_tb.vhh:104:16:error: target is not a signal name

There's no ddr controller in the ice40, yes. It wouldn't fit, and there's no
lpddr2 hardare attached to any ice40 board we've got. (I suspect that one's
testing a xilinx emulation configuration? That's a Jeff question.)

> and the first one multiple times for different lines
> ghdl_up5k.sh lacks a folder/file describing the display controller.
> error: cannot open ../disp_drv/disp_drv_pkg.vhd

That might be for the calculator board Jeff's building? Dunno.

> This causes more errors in things that depend on the content of this file:
> ghdl:error: compilation error
> cpu_up5k_42s.vhd:9:10:error: unit "disp_drv_pkg" not found in library "work"
> cpu_up5k_42s.vhd:31:14:error: entity 'cpu_up5k' was not analysed
> ghdl:error: compilation error
> error: cannot find entity or configuration up5k_tb
> ghdl:error: compilation error
> Should issues about the ice40 release be raised on GitHub (to signal
> project activity) or on the mailing list?

I prefer the mailing list, but lots of people use github these days...

> ghdl_lattice.sh seems to work but i am unsure how to replace the
> executed binary. This is however not a priority for me since I have a
> dev board.

That's the one I ran, and the only version of ghdl I could get to work was the
interpreter not the standalone one. (I downloaded ghdl-gpl-0.36-mcode.tgz on
Linux rather than the llvm backend version Jeff's using on Apple, the llvm one
had some dependency I couldn't figure out how to satisfy on Devuan...)

We need to do a proper writeup of this (and how to install the lattice toolchain
to build bitstreams).

> Sincerely,
> Johann-Tobias Schäg


More information about the J-core mailing list