[J-core] Linux SH build issues with 4.14

Rob Landley rob at landley.net
Fri Dec 8 14:50:31 EST 2017

Flew back from Tokyo to Austin, still not quite recovered yet but
catching up...

On 12/03/2017 02:30 AM, John Paul Adrian Glaubitz wrote:
> On 12/03/2017 09:29 AM, Rob Landley wrote:
>>>> https://anonscm.debian.org/cgit/kernel/linux.git/tree/debian/config/config
>>>> https://anonscm.debian.org/cgit/kernel/linux.git/tree/debian/config/sh4/config*
>>> Compiler is gcc-7.
>> I'm using 6.3.0 here.
> Yes, but Debian already defaults to 7. It needs to be fixed with gcc-7,
> especially since gcc is moving forward so fast these days.

Ok, I built 4.14 with musl-cross-make's gcc 7.2.0 and it's working fine?

I grabbed https://github.com/landley/mkroot and extracted 4.14 into
download/linux with the serial port fixing patch, grabbed
https://github.com/richfelker/musl-cross-make, edited the makefile of
the to select 7.2.0 for the gcc version, used mkroot's mcm-buildall.sh
script to build all the compilers (which took hours), created the mcm
symlink to that's output directory, then did "./cross.sh sh4 ./mkroot
kernel" then cd output/sh4 and ran ./qemu-sh4.sh to launch it under qemu.

It all worked fine, and did not reproduce the issue you're describing?

If you _are_ getting gcc inserting a spurious call to abort() because
they don't care about breaking the kernel build, it sounds like all you
need to do to work around it is stick this somewhere in the kernel code:

  void abort(void) { panic(); }

But that's just a guess, I'm still not reproducing your issue,


More information about the J-core mailing list