[J-core] MimasV2Config.py issues

Rob Landley rob at landley.net
Fri Apr 15 22:54:41 EDT 2016

On 04/15/2016 08:27 PM, Christopher Friedt wrote:
> I'm getting a slightly odd looking error [1].
> Tried this using two setups
> 1) Ubuntu 15.10 in VMWare Fusion on a Mac
> 2) Natively on Mac
> Same error in both cases. Am I missing some other python module?

No, there's some sort of bug in the python3-serial package. I sometimes
had to cursor up and hit enter to try again a dozen times before it caught.

As soon as you get 0% flashed, it works fine and never fails
verification. But something about the initial negotiation is bouncy on
ubuntu. (Rich says it's rock solid on alpine linux, but on ubuntu 14.04
it's really buggy. It's like it doesn't flush pending data when you open
the thing and reads old noise, or something? I'd blame python 3, but
given that I've seen two other really annoying bugs since upgrading from
12.04 to 14.04...)

Retry and see what happens? (And by retry I mean several times.)

I have a todo item to make the python script itself retry internally.
Ideally we'd fix python3-serial in ubuntu, but nobody else seems to use
python 3 for anything.)


More information about the J-core mailing list